SMFPortal.de

Archiv => 1.x Administration => Thema gestartet von: tommihart am 05. September 2017, 00:45:27

Titel: Neue Frage zu "Unknown column 'add_deny' in 'field list'"
Beitrag von: tommihart am 05. September 2017, 00:45:27
Wieder ich..

also... was ich nunmehr nach meinem letzten Thread gemacht habe ist:

- SMF 1.1.21 wieder lauffähig hinbekommen (php5, SQL 4)
- 2. SQL Datenbank auf anderem Webspace eingerichtet (php7, SQL 5)
- SMF 2.0.14 dort blank installiert mit leerer Datenbank
- danach die Datenbank wieder gelöscht, weil ansonsten irgendwie der Import der alten nicht funktioniert hat
- neue Datenbank angelegt
- Import des Backups der alten Datenbank (so wird es online ja überall auch empfohlen, einfach die 4er SQL in eine leere 5er importieren)

Das ganze hat mich mit vielem hin und her schon ca. 4 Stunden gekostet.. puh.. und nun, wo alles laufen sollte, kommt die Fehlermeldung

Unknown column 'add_deny' in 'field list'

beim Starten der Seite (liegt unter testbwf.logopaedie-schweinheim.de)

google hilft mir nicht wirklich. Ich habe in den letzten Tagen wirklich viel gelernt, aber das übersteigt momentan meine Ahnung und meine Kräfte.. hat jemand einen Rat?

Hätte nie gedacht dass das alles so kompliziert sein muss...  :(
Titel: Re: Neue Frage zu "Unknown column 'add_deny' in 'field list'"
Beitrag von: Parmaster am 05. September 2017, 09:25:19
Die Datenbank von SMF 1 kann man nicht in SMF 2 importieren.

Du musst vorher das Upgrade machen, da auch die Datenbank geändert wurde.
Titel: Re: Neue Frage zu "Unknown column 'add_deny' in 'field list'"
Beitrag von: tommihart am 05. September 2017, 09:48:03
ok.. hatte das nur so in ein, zwei Anleitungen gelesen wo es auch um das Update von 1.x auf 2.x ging...

Ich muss also auf dem Testserver eine blanke 1.1.21 aufspielen und da dann das Upgrade auf 2.0.14 aufspielen.

Aber wann mache ich denn dann das php Update und spiel die 5er SQL ein? Denn php7 und SQL 5 funzt ja nicht mit 1.1.21, andererseits läuft 2.0.14 nicht mit php 5 und SQL 4... da drehe ich mich ein wenig im Kreis gerade...

Nehmen wir nun also an, ich möchte (ohne Testserver) das momentan laufende 1.1.21 updaten. In welcher Reihenfolge muss ich denn dann

- php
- SQL
- SMF updaten

damit das fehlerfrei funktioniert?

(Gott sei Dank weiß ich ja inzwischen wie ich jederzeit wieder alles platt machen und neu installieren kann ^^)
Titel: Re: Neue Frage zu "Unknown column 'add_deny' in 'field list'"
Beitrag von: Parmaster am 05. September 2017, 10:18:07
Mach zuerst das Upgrade deines vorhandenen Forums, nicht ein neues installieren.

Dann kannst du davon ein Backup der Datenbank machen, DB aktualisieren, DB importieren.
Titel: Re: Neue Frage zu "Unknown column 'add_deny' in 'field list'"
Beitrag von: tommihart am 05. September 2017, 10:21:18
aber genau das hatten wir doch schon versucht mit dem Upgrade des Forums, das hatte doch (scheinbar wegen der alten php Version) nicht funktioniert  :(

Oder soll ich dann so vorgehen:

- php hochsetzen (auch wenn das alte damit dann nicht mehr laufen würde)
- Upgrade des Forums
- Datenbank Backup
- 4er Datenbank löschen
- 5er Datenbank installieren
- Backup einspielen

?

Oder anders gefragt - wie ist denn Dein Stundensatz wenn ich Dich beauftrage damit?  :P
Titel: Re: Neue Frage zu "Unknown column 'add_deny' in 'field list'"
Beitrag von: Parmaster am 05. September 2017, 11:27:30
Ich hatte gar nichts probiert.

Wie soll das Upgrade laufen, wenn du PHP hoch setzt, und aber alles über PHP läuft?

Mal davon abgesehen, wo steht das überhaupt mit den PHP/MySQL Versionen?
Titel: Re: Neue Frage zu "Unknown column 'add_deny' in 'field list'"
Beitrag von: tommihart am 05. September 2017, 11:53:48
nein, hattest Du nicht, aber ich.

Ich denke das Upgrade braucht einfach schon die höhere php-Version?

Basis Server Requirements (https://download.simplemachines.org/requirements.php) sagt php 5.4 für SMF 2.0, ich hab 5.2.7. Und: "Versions of SMF below 2.0.7 will not work on PHP 5.5. If you use PHP 5.5 it is required to use SMF 2.0.7 or greater. "

Deswegen die Überlegung erst die php-Version hochzusetzen und dann das Large Upgrade zu starten. Theoretisch sollte das ja sogar schon reichen. Wenns kracht kann ich ja die Version wieder zurücksetzen und alles zurückspielen wie es momentan ist.

SQL sollte gemäß der Seite sogar ausreichen mit Version 4.1.22.

Sorry für das ständige Nachfragen, aber ich bin mir in dem Bereich halt einfach unsicher und möchte vermeiden, am Ende alles "zu zerstören".

Oder ich such mir einfach jemanden der es durchführen kann - dann werden meine grauen Haare auch nicht mehr  :)
Titel: Re: Neue Frage zu "Unknown column 'add_deny' in 'field list'"
Beitrag von: Parmaster am 05. September 2017, 12:04:30
Dann setz PHP hoch, und führe das Upgrade aus.
Titel: Re: Neue Frage zu "Unknown column 'add_deny' in 'field list'"
Beitrag von: tommihart am 05. September 2017, 12:27:28
ok, danke  :)

EDIT

nur zur Info - hat nicht gefunzt. Ich such mir jetzt einfach jemanden der das machen kann.