24. November 2017, 23:17:45
SMFPortal.de

Autor Thema: Hilfe gesucht: Fehler 8: Undefined index: spoiler (Version 1.1.21)  (Gelesen 492 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

31. August 2017, 23:41:36
Antwort #15

Parmaster

Administration
Ok, ich weiß was es ist. Da muss man erst mal drauf kommen wenn man direkt in der Datei runter scrollt.

Da hat wohl schon jemand das Upgrade für SMF 2 hochgeladen, aber nicht ausgeführt.

Nun schwirren da Dateien rum, die schon Version 2 haben, andere noch 1.1.21.

Kein Wunder das nichts funktioniert.

Ich rate dir dringend, das Upgrade auszuführen.

Also, das komplett Upgrade hochladen, alle Dateien überschreiben lassen, dann das Upgrade anstoßen und laufen lassen.
Alternativ, alle Dateien mit der Version 1.1.21 ersetzen.

So wird das auf jeden Fall nichts.

EDIT:

und wo zum Henker ist die Settings.php?
« Letzte Änderung: 31. August 2017, 23:44:51 von Parmaster »
Eine digitale Welt zur Neugestaltung des menschlichen Daseins

01. September 2017, 00:21:10
Antwort #16

tommihart


ich frag jetzt besser nicht wie sowas auf einmal passieren kann...? Ist ja mehr als dubios...

Ok, also komplettes Update... laufe ich Gefahr damit irgendwas kaputt zu machen?

Die Settings.php ist doch unter /webseiten/? Oder gehört sie da nicht hin?

Ich bin gerade schon am gucken... ist als Laie in Forensoftware nicht so easy....

Ah, habe gerade hier das Thema "Update und Upgrade" gefunden  :D

___________________

Probiert nach der Anleitung.

Version 2 heruntergeladen, Sprachdateien auch.

Backup per FTP und von der SQL-DB gemacht.

Sprachdateien zuerst hochgeladen, danach dann den Rest.

Upgrade.php gestartet.

Meldung: Fatal error: Function name must be a string in /kunden/212587_63762/webseiten/upgrade.php on line 854

Frage: kann ich den nicht einfach alles löschen, 2.0.x sauber installieren und dann irgendwie versuchen das neue mit der Datenbank zu verbinden? Oder stelle ich mir das zu einfach vor?
« Letzte Änderung: 01. September 2017, 00:47:47 von tommihart »

01. September 2017, 01:00:35
Antwort #17

Parmaster

Administration
Nein, das geht nicht, du musst schon das Upgrade ausführen, da auch sehr viel in der Datenbank geändert wurde.


EDIT:

spiel bitte das Backup vom FTP nochmal komplett zurück ohne das Upgrade auszuführen (wenns noch möglich ist).
« Letzte Änderung: 01. September 2017, 01:02:49 von Parmaster »
Eine digitale Welt zur Neugestaltung des menschlichen Daseins

01. September 2017, 08:04:46
Antwort #18

tommihart


bin gerade dabei (also kopiere halt einfach zurück...)

01. September 2017, 23:22:14
Antwort #19

tommihart


Frage:

Ein aktuelles Backup der Datenbank habe ich ja. Ich gehe mal davon aus, dass da drinnen alles gespeichert ist wie Aufbau des Forums, Anmeldenamen, Beitragszähler usw.?

Ist denn dann ein gängiger Weg per FTP alles platt zu machen, die 1.1.12 neu zu installieren, dann die Datenbank anzubinden und dann auf grüner Wiese das Update auf 2.0.14 (glaube ich) zu fahren? Oder liege ich da komplett falsch?

02. September 2017, 10:44:46
Antwort #20

Parmaster

Administration
Eine digitale Welt zur Neugestaltung des menschlichen Daseins

02. September 2017, 12:02:20
Antwort #21

tommihart


Puh, ich versuche es...

muss ich den alten Forenaufbau dafür noch kennen (Bereiche usw.) oder kommt das dann auch aus der Datenbank? Also nur blanko installieren und die DB "irgendwie" rankoppeln?

EDIT:

Ok... bislang grünes Licht.. beim Einrichten der Datenbank kam nun folgendes:

The installer has detected another version of SMF already installed with the specified information. If you are trying to upgrade, you should use the upgrader, not the installer.

Otherwise, you may wish to use different information, or create a backup and then delete the data currently in the database.


Was heißt das? Datenbank hat schon neuere SMF-Version? Wie kann ich die herausfinden? Wie kann ich das lösen?  :o

EDIT:

LMAA, der Krempel geht... zumindest in der Version 1.1.21 wieder.. versuch dann gleich mal das Update durchzuführen... danach kommt dann die Dankes-Arie hier an Dich  :D
« Letzte Änderung: 02. September 2017, 13:27:28 von tommihart »

02. September 2017, 13:23:30
Antwort #22

Parmaster

Administration
Hast du ein Backup der Datenbank?

Wenn ja, lade das Upgrade hoch, und führe dies direkt aus, dann brauchst du nicht erst 1.1.21 zu installieren.
Eine digitale Welt zur Neugestaltung des menschlichen Daseins

02. September 2017, 13:32:19
Antwort #23

tommihart


Upgrade geht nach wie vor nicht - gleicher Fehler wie beim letzten Mal.

Ich installier nun also nochmal ne saubere 1.1.21, dann funzt zumindest erstmal alles...

EDIT

Wir sind erstmal wieder online - zwar nur auf Englisch, da die deutsche Sprachdatei irgendwie nicht will (oder ich die noch umstellen muss, schau ich gleich - ist nunmehr gefixed, aber nur in einem Theme), aber wir sind wieder da.

Wenn Du mir noch Hilfe beim nicht funktionierenden Upgrade geben kannst freue ich mich noch viel mehr - mein Dank ist Dir jetzt schon ewig gewiss für die Hilfe  :)

EDIT:

Gerade festgestellt dass die momentane php-Version die 5.2.17 ist, die wohl mit der 2er-Version nicht funktioniert. Ein neuer Versuch eben (php auf Stable-7 hochgesetzt, Upgrade gestartet) hat aber auch nix gebracht.
« Letzte Änderung: 03. September 2017, 00:15:56 von tommihart »

 

Internes

Nutzungsbedingungen Impressum

Wissenswertes

Hilfe Knowledge Base

Nützliches

Downloads Kleinanzeigen Socialmedia